]> git.pld-linux.org Git - packages/perl-Math-Round.git/blob - perl-Math-Round.spec
- macros for perl autodeps
[packages/perl-Math-Round.git] / perl-Math-Round.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Math
6 %define pnam    Round
7 Summary:        Math::Round - Perl extension for rounding numbers
8 Summary(pl.UTF-8):      Math::Round - perlowe rozszerzenie do zaokrąglania liczb
9 Name:           perl-Math-Round
10 Version:        0.07
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b74c5d2a3f891c19dafd7ce638732fd1
17 URL:            https://metacpan.org/release/Math-Round
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Math::Round supplies functions that will round numbers in different
26 ways. The functions round and nearest are exported by default; others
27 are available as described in the manual. "use ... qw(:all)" exports
28 all functions.
29
30 %description -l pl.UTF-8
31 Math::Round udostępnia funkcje zaokrąglające liczby w różny sposób.
32 Funkcje round i nearest są eksportowane domyślnie; inne są dostępne w
33 sposób opisany w manualu. "use ... qw(:all)" eksportuje wszystkie
34 funkcje.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/Math/Round.pm
59 %dir %{perl_vendorlib}/auto/Math/Round
60 %{perl_vendorlib}/auto/Math/Round/autosplit.ix
61 %{_mandir}/man3/Math::Round.3pm*
This page took 0.059652 seconds and 3 git commands to generate.