]> git.pld-linux.org Git - packages/perl-Math-Round.git/blob - perl-Math-Round.spec
c6a30285cc77bc57bcdb5ec117fc9e3b40a4c549
[packages/perl-Math-Round.git] / perl-Math-Round.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Math
6 %define pnam    Round
7 Summary:        Math::Round - Perl extension for rounding numbers
8 Summary(pl.UTF-8):      Math::Round - perlowe rozszerzenie do zaokrąglania liczb
9 Name:           perl-Math-Round
10 Version:        0.07
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b74c5d2a3f891c19dafd7ce638732fd1
17 URL:            http://search.cpan.org/dist/Math-Round/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Math::Round supplies functions that will round numbers in different
25 ways. The functions round and nearest are exported by default; others
26 are available as described in the manual. "use ... qw(:all)" exports
27 all functions.
28
29 %description -l pl.UTF-8
30 Math::Round udostępnia funkcje zaokrąglające liczby w różny sposób.
31 Funkcje round i nearest są eksportowane domyślnie; inne są dostępne w
32 sposób opisany w manualu. "use ... qw(:all)" eksportuje wszystkie
33 funkcje.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/Math/Round.pm
58 %dir %{perl_vendorlib}/auto/Math/Round
59 %{perl_vendorlib}/auto/Math/Round/autosplit.ix
60 %{_mandir}/man3/Math::Round.3pm*
This page took 0.083716 seconds and 2 git commands to generate.