]> git.pld-linux.org Git - packages/perl-Math-Matlab.git/blob - perl-Math-Matlab.spec
4b403b053c52b28fd685177b21453ec2f298f477
[packages/perl-Math-Matlab.git] / perl-Math-Matlab.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't require packages only for autodeps generation
4 %bcond_with     tests           # perform "make test" (requires Matlab installation)
5 # matlab                        # command to execute matlab
6 #
7 %include        /usr/lib/rpm/macros.perl
8 %define         pdir    Math
9 %define         pnam    Matlab
10 Summary:        Math::Matlab - interface for running Matlab programs from Perl
11 Summary(pl.UTF-8):      Math::Matlab - interfejs do uruchamiania programów Matlaba z poziomu Perla
12 Name:           perl-Math-Matlab
13 Version:        0.08
14 Release:        1
15 # same as perl
16 License:        GPL v1+ or Artistic
17 Group:          Development/Languages/Perl
18 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
19 # Source0-md5:  fcab9a197d49dd5453f9d82de0ca7382
20 %if %{with autodeps}
21 BuildRequires:  apache-mod_perl
22 BuildRequires:  perl-URI
23 BuildRequires:  perl-libapreq2
24 BuildRequires:  perl-libwww
25 %endif
26 %if %{with tests}
27 BuildRequires:  perl-Test-Simple >= 0.01
28 %endif
29 BuildRequires:  perl-devel >= 1:5.8.0
30 BuildRequires:  rpm-perlprov >= 4.1-13
31 #Requires:      matlab
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %{!?matlab:%define      matlab  /usr/local/bin/matlab -nodisplay -nojvm}
36
37 %description
38 The Math::Matlab package provides an interface for running Matlab
39 programs from Perl and capturing the output (what the Matlab program
40 prints to STDOUT) into a string. For more information on Matlab see
41 The MathWorks web-site at <http://www.mathworks.com/>.
42
43 %description -l pl.UTF-8
44 Pakiet Math::Matlab udostępnia interfejs do uruchamiania programów
45 Matlaba z poziomu Perla i przechwytywania wyjścia (tego, co programy
46 Matlaba wypisują na STDOUT) do łańcucha. Więcej informacji o Matlabie
47 można znaleźć na stronie MathWorks pod adresem
48 <http://www.mathworks.com/>.
49
50 %package Remote
51 Summary:        Math::Matlab::Remote - interface to a remote Matlab process
52 Summary(pl.UTF-8):      Math::Matlab::Remote - interfejs do zdalnego procesu Matlaba
53 Group:          Development/Languages/Perl
54 Requires:       %{name} = %{version}-%{release}
55
56 %description Remote
57 Math::Matlab::Remote implements an interface to a remote Matlab server
58 (see Math::Matlab::Server). It uses the LWP package to access the
59 server via the HTTP protocol. The Remote object has the URI of the
60 server, a timeout value for the requests and a user name and password
61 used for basic authentication of the request.
62
63 %description Remote -l pl.UTF-8
64 Math::Matlab::Remote to implementacja interfejsu do zdalnego serwera
65 Matlaba (moduł Math::Matlab::Server). Używa pakietu LWP do dostępu do
66 serwera za pośrednictwem protokołu HTTP. Obiekt Remote zawiera URI do
67 serwera, wartość maksymalnego czasu oczekiwania dla żądań oraz nazwę
68 użytkownika i hasło do prostego uwierzytelniania żądania.
69
70 %package Server
71 Summary:        Math::Matlab::Server - a Matlab server as a mod_perl content handler
72 Summary(pl.UTF-8):      Math::Matlab::Server - serwer Matalaba jako obsługa treści dla mod_perla
73 Group:          Development/Languages/Perl
74 Requires:       %{name} = %{version}-%{release}
75
76 %description Server
77 Math::Matlab::Server implements a mod_perl content handler which takes
78 form input arguments named CODE, REL_MWD and RAW_OUTPUT, calls the
79 execute() method of the server's Math::Matlab object passing the CODE
80 and REL_MWD arguments, and sends back the results as a 'text/plain'
81 document. The results are the value returned by the object's
82 fetch_raw_result() or fetch_result() method, depending whether or not
83 the RAW_OUTPUT parameter is true.
84
85 %description Server -l pl.UTF-8
86 Math::Matlab::Server to implementacja funkcji obsługi generowania
87 treści dla mod_perla, przyjmująca z wejścia formularza argumenty o
88 nazwach CODE, REL_MWD i RAW_OUTPUT, wywołująca metodę execute()
89 obiektu Math::Matlab na serwerze przekazując argumenty CODE i REL_MWD,
90 a następnie odsyłająca wyniki jako dokument text/plain. Wyniki to
91 wartość zwrócona przez metodę fetch_raw_result() lub fetch_result()
92 obiektu, w zależności od wartości parametru RAW_OUTPUT.
93
94 %prep
95 %setup -q -n %{pdir}-%{pnam}-%{version}
96
97 %build
98 echo "%{matlab}" | \
99 %{__perl} Makefile.PL \
100         INSTALLDIRS=vendor
101
102 %{__make}
103
104 %{?with_tests:%{__make} test}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %doc Changes README
118 %{perl_vendorlib}/Math/Matlab.pm
119 %dir %{perl_vendorlib}/Math/Matlab
120 %{perl_vendorlib}/Math/Matlab/Local.pm
121 %{perl_vendorlib}/Math/Matlab/Pool.pm
122 %{_mandir}/man3/*
123
124 %files Remote
125 %defattr(644,root,root,755)
126 %{perl_vendorlib}/Math/Matlab/Remote.pm
127
128 %files Server
129 %defattr(644,root,root,755)
130 %doc INSTALL server.config
131 %{perl_vendorlib}/Math/Matlab/Server.pm
This page took 0.084043 seconds and 2 git commands to generate.