]> git.pld-linux.org Git - packages/perl-Math-MagicSquare.git/blob - perl-Math-MagicSquare.spec
4d3bb5dcb53a298bcae1f44515befc7c41938a82
[packages/perl-Math-MagicSquare.git] / perl-Math-MagicSquare.spec
1 #
2 # Conditional build:
3 # one test is completly broken
4 %bcond_with     tests   # do perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Math
8 %define         pnam    MagicSquare
9 Summary:        Math::MagicSquare Perl module - magic square checker
10 Summary(pl.UTF-8):      Moduł Perla Math::MagicSquare - sprawdzanie kwadratów magicznych
11 Name:           perl-Math-MagicSquare
12 Version:        2.04
13 Release:        2
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  c9d5b59f9c3a9a8419dc92b02b14d698
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The first purpose of this Perl module is to help you to check your
26 Square. Is it a Semimagic Square? Is it a Magic Square?
27
28 The second purpose of this Perl module is to help you to print your
29 Square. At the moment the method available is 'print' that prints the
30 square on STDOUT and 'printhtml' that prints the square in HTML
31 format.
32
33 The third purpose of this Perl module is to help you to manipulate
34 your Square. At the moment the available methods are 'rotation' that
35 rotates your Square of 90 degree clockwise and 'reflection' that
36 reflect your Square.
37
38 %description -l pl.UTF-8
39 Pierwszym celem tego modułu Perla jest pomoc przy sprawdzaniu
40 kwadratów. Czy kwadrat jest semimagiczny? Czy jest magiczny?
41
42 Drugim celem jest pomoc przy wypisywaniu kwadratów. Aktualnie jest
43 dostępna metoda 'print' wypisująca kwadrat na standardowe wyjście oraz
44 metoda 'printhtml' wypisująca w formacie HTML.
45
46 Trzecim celem tego modułu jest pomoc przy modyfikowaniu kwadratu.
47 Aktualnie dostępna jest metoda 'rotation' obracająca kwadrat o 90
48 stopni zgodnie z kierunkiem ruchu wskazówek zegara oraz metoda
49 'reflection' dokonująca odbicia lustrzanego kwadratu.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README TODO HISTORY
72 %{perl_vendorlib}/%{pdir}/%{pnam}.pm
73 %{_mandir}/man3/*
This page took 0.073261 seconds and 2 git commands to generate.