]> git.pld-linux.org Git - packages/perl-Math-MagicSquare-Generator.git/blob - perl-Math-MagicSquare-Generator.spec
use generic url
[packages/perl-Math-MagicSquare-Generator.git] / perl-Math-MagicSquare-Generator.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    MagicSquare-Generator
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Math::MagicSquare::Generator - Magic Square generator
9 Summary(pl.UTF-8):      Math::MagicSquare::Generator - generator kwadratów magicznych
10 Name:           perl-Math-MagicSquare-Generator
11 Version:        0.01
12 Release:        2
13 License:        Public Domain
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  408501cf0474f95234eb1bfdb4832d42
17 URL:            http://search.cpan.org/dist/Math-MagicSquare-Generator/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module creates magic squares. A magic square is a square in which
25 all numbers are different and the sums of all rows, all columns and
26 the two diagonals are equal.
27
28 Math::MagicSquare::Generator cannot create panmagic squares, or
29 squares that have an even size. (A panmagic square is magic square
30 where the "wrapped" diagonals are also equal.)
31
32 %description -l pl.UTF-8
33 Ten moduł tworzy kwadraty magiczne. Kwadrat magiczny to kwadrat, w
34 którym wszystkie liczby są różne, a sumy we wszystkich wierszach, we
35 wszystkich kolumnach i na dwóch przekątnych są równe.
36
37 Math::MagicSquare::Generator nie potrafi tworzyć kwadratów
38 panmagicznych ani kwadratów o parzystym rozmiarze (kwadrat panmagiczny
39 to kwadrat magiczny, w którym sumy na "zawiniętych" przekątnych są
40 także równe).
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %dir %{perl_vendorlib}/Math/MagicSquare
66 %{perl_vendorlib}/Math/MagicSquare/Generator.pm
67 %{_mandir}/man3/*
This page took 0.104469 seconds and 3 git commands to generate.