]> git.pld-linux.org Git - packages/perl-Math-MagicSquare-Generator.git/blob - perl-Math-MagicSquare-Generator.spec
68e74bc6abf4ec962c6aeb71ec7edb7faab21d5a
[packages/perl-Math-MagicSquare-Generator.git] / perl-Math-MagicSquare-Generator.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    MagicSquare-Generator
8 Summary:        Math::MagicSquare::Generator - Magic Square generator
9 Summary(pl.UTF-8):      Math::MagicSquare::Generator - generator kwadratów magicznych
10 Name:           perl-Math-MagicSquare-Generator
11 Version:        0.01
12 Release:        2
13 License:        Public Domain
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  408501cf0474f95234eb1bfdb4832d42
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module creates magic squares. A magic square is a square in which
24 all numbers are different and the sums of all rows, all columns and
25 the two diagonals are equal.
26
27 Math::MagicSquare::Generator cannot create panmagic squares, or
28 squares that have an even size. (A panmagic square is magic square
29 where the "wrapped" diagonals are also equal.)
30
31 %description -l pl.UTF-8
32 Ten moduł tworzy kwadraty magiczne. Kwadrat magiczny to kwadrat, w
33 którym wszystkie liczby są różne, a sumy we wszystkich wierszach,
34 we wszystkich kolumnach i na dwóch przekątnych są równe.
35
36 Math::MagicSquare::Generator nie potrafi tworzyć kwadratów
37 panmagicznych ani kwadratów o parzystym rozmiarze (kwadrat panmagiczny
38 to kwadrat magiczny, w którym sumy na "zawiniętych" przekątnych są
39 także równe).
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %dir %{perl_vendorlib}/Math/MagicSquare
65 %{perl_vendorlib}/Math/MagicSquare/Generator.pm
66 %{_mandir}/man3/*
This page took 0.076193 seconds and 2 git commands to generate.