]> git.pld-linux.org Git - packages/perl-Math-Integral-Romberg.git/blob - perl-Math-Integral-Romberg.spec
23ade57628c8ea9b0dec9aa9e47b421d1052469a
[packages/perl-Math-Integral-Romberg.git] / perl-Math-Integral-Romberg.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    Integral-Romberg
8 Summary:        Math::Integral::Romberg - scalar numerical integration
9 Summary(pl.UTF-8):      Math::Integral::Romberg - całkowanie numeryczne
10 Name:           perl-Math-Integral-Romberg
11 Version:        0.02
12 %define _ver    %(echo %{version} | tr . _)
13 Release:        3
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{_ver}.tar.gz
18 # Source0-md5:  932ea744c11f34b5506a14637ef0421a
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Math::Integral::Romberg module numerically estimates the integral of
26 function using Romberg integration, a faster relative of Simpson's
27 method.
28
29 %description -l pl.UTF-8
30 Moduł Math::Integral::Romberg numerycznie przybliża wartość całki
31 funkcji przy użyciu całkowania Romberga, szybszego niż metoda
32 Simpsona.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README Release
56 %dir %{perl_vendorlib}/Math/Integral
57 %{perl_vendorlib}/Math/Integral/Romberg.pm
58 %{_mandir}/man3/*
This page took 0.12847 seconds and 2 git commands to generate.