]> git.pld-linux.org Git - packages/perl-Math-HashSum.git/blob - perl-Math-HashSum.spec
use generic url
[packages/perl-Math-HashSum.git] / perl-Math-HashSum.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    HashSum
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Math::HashSum - sum a list of key-value pairs on a per-key basis
9 Summary(pl.UTF-8):      Math::HashSum - sumowanie listy par klucz-wartość na podstawie klucza
10 Name:           perl-Math-HashSum
11 Version:        0.02
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  fe474ff52a3ce086e9887d821f784f5a
18 URL:            http://search.cpan.org/dist/Math-HashSum/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module allows you to sum a list of key-value pairs on a per-key
26 basis. It adds up all the values associated with each key in the given
27 list and returns a hash containing the sum associated with each key.
28
29 %description -l pl.UTF-8
30 Ten moduł pozwala zsumować listę par klucz-wartość na podstawie
31 klucza. Dodaje wszystkie wartości związane z każdym kluczem z podanej
32 listy i zwraca hash zawierający sumę związaną z każdym kluczem.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc CHANGES README
57 %{perl_vendorlib}/Math/HashSum.pm
58 %{_mandir}/man3/*
This page took 0.092053 seconds and 3 git commands to generate.