]> git.pld-linux.org Git - packages/perl-Math-GSL.git/blob - perl-Math-GSL.spec
- updated BRs
[packages/perl-Math-GSL.git] / perl-Math-GSL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    GSL
8 Summary:        Math::GSL Perl module - resticted interface to GNU Scientific Library
9 Summary(pl.UTF-8):      Moduł Perla Math::GSL - ograniczony interfejs do GNU Scientific Library
10 Name:           perl-Math-GSL
11 Version:        0.39
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  6bbcb412e230d3e1602164e15767d102
18 Patch0:         %{name}-inc.patch
19 Patch1:         %{name}-update.patch
20 URL:            http://search.cpan.org/dist/Math-GSL/
21 BuildRequires:  gsl-devel >= 1.15
22 BuildRequires:  perl-Module-Build >= 0.38
23 BuildRequires:  perl-PkgConfig >= 0.07720
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRequires:  swig-perl
27 %if %{with tests}
28 BuildRequires:  perl-Test-Class >= 0.12
29 BuildRequires:  perl-Test-Differences
30 BuildRequires:  perl-Test-Exception >= 0.21
31 BuildRequires:  perl-Test-Most >= 0.31
32 BuildRequires:  perl-Test-Taint >= 1.06
33 BuildRequires:  perl-version >= 0.77
34 %endif
35 Requires:       gsl >= 1.15
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Math::GSL Perl module is a very resticted perl interface to -lgsl -
40 GNU Scientific Library. Only the routines relating the solving of
41 polynomials are exported. It exists to provide that function to
42 "tkscope" in Audio::Data.
43
44 %description -l pl.UTF-8
45 Moduł Perla Math::GSL stanowi bardzo ograniczony interfejs do -lgsl -
46 Biblioteki Naukowej GNU (GNU Scientific Library). Eksportuje jedynie
47 funkcje dotyczące rozwiązywania równań wielomianowych. Istnieje, aby
48 udostępnić te funkcje "tkscope" w module Audio::Data.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52 %patch0 -p1
53 %patch1 -p1
54
55 # simulate non-release to force swig rebuild
56 mkdir .git
57
58 %build
59 %{__perl} Build.PL \
60         config="optimize='%{rpmcflags}'" \
61         destdir=$RPM_BUILD_ROOT \
62         installdirs=vendor
63 ./Build
64
65 %{?with_tests:./Build test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 ./Build install
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc CREDITS Changes KNOWN_BUGS README.md TODO
78 %{perl_vendorarch}/Math/GSL.pm
79 %{perl_vendorarch}/Math/GSL
80 %dir %{perl_vendorarch}/auto/Math/GSL
81 %dir %{perl_vendorarch}/auto/Math/GSL/*
82 %attr(755,root,root) %{perl_vendorarch}/auto/Math/GSL/*/*.so
83 %{_mandir}/man3/Math::GSL*.3pm*
This page took 0.072154 seconds and 3 git commands to generate.