]> git.pld-linux.org Git - packages/perl-Math-Factor-XS.git/blob - perl-Math-Factor-XS.spec
- release 2 (by relup.sh)
[packages/perl-Math-Factor-XS.git] / perl-Math-Factor-XS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    Factor-XS
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Math::Factor::XS - Factorize numbers and calculate matching multiplications
9 Name:           perl-Math-Factor-XS
10 Version:        0.40
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  fec7d1291fd9fecebe316d57f2a16cd3
17 URL:            http://search.cpan.org/dist/Math-Factor-XS/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-List-MoreUtils
23 BuildRequires:  perl-Params-Validate
24 BuildRequires:  perl-boolean
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Math::Factor::XS factorizes numbers by applying trial divisions.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Build.PL \
36         destdir=$RPM_BUILD_ROOT \
37         installdirs=vendor
38 ./Build
39
40 %{?with_tests:./Build test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 ./Build install
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes INSTALL README
53 %dir %{perl_vendorarch}/Math/Factor
54 %{perl_vendorarch}/Math/Factor/XS.pm
55 %dir %{perl_vendorarch}/auto/Math/Factor
56 %dir %{perl_vendorarch}/auto/Math/Factor/XS
57 %{perl_vendorarch}/auto/Math/Factor/XS/XS.bs
58 %attr(755,root,root) %{perl_vendorarch}/auto/Math/Factor/XS/XS.so
59 %{_mandir}/man3/*
This page took 0.057659 seconds and 3 git commands to generate.