]> git.pld-linux.org Git - packages/perl-Math-ErrorPropagation.git/blob - perl-Math-ErrorPropagation.spec
use generic url
[packages/perl-Math-ErrorPropagation.git] / perl-Math-ErrorPropagation.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    ErrorPropagation
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Math::ErrorPropagation - computes the error of a function of statistical data
9 Summary(pl.UTF-8):      Math::ErrorPropagation - obliczanie błędu funkcji danych statystycznych
10 Name:           perl-Math-ErrorPropagation
11 Version:        0.01
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  089bc0978360afc1e9ba94767975cb8f
18 URL:            http://search.cpan.org/dist/Math-ErrorPropagation/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Harness
23 BuildRequires:  perl-Test-Simple
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This package allows the propagation of errors on the variables through
30 various simple mathematical operations to automatically compute the
31 error of the function.
32
33 %description -l pl.UTF-8
34 Ten pakiet pozwala na automatycznie obliczanie błędu funkcji
35 powstałego z propagacji błędów na zmiennych poprzez różne proste
36 operacje matematyczne.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Math/ErrorPropagation.pm
61 %{_mandir}/man3/*
This page took 0.052801 seconds and 3 git commands to generate.