]> git.pld-linux.org Git - packages/perl-Math-CatmullRom.git/blob - perl-Math-CatmullRom.spec
use generic url
[packages/perl-Math-CatmullRom.git] / perl-Math-CatmullRom.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    CatmullRom
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Math::CatmullRom - calculate Catmull-Rom splines
9 Summary(pl.UTF-8):      Math::CatmullRom - obliczanie splajnów Catmulla-Roma
10 Name:           perl-Math-CatmullRom
11 Version:        0.00
12 Release:        2
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c924e04872eed511e9b6f7c43af2af45
17 URL:            http://search.cpan.org/dist/Math-CatmullRom/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module provides an algorithm to generate plots for Catmull-Rom
25 splines.
26
27 A Catmull-Rom spline can be considered a special type of Bezier curve
28 that guarantees that the curve will cross every control point starting
29 at the second point and terminating at the penultimate one. For this
30 reason the minimum number of control points is 4.
31
32 %description -l pl.UTF-8
33 Ten moduł udostępnia algorytm do generowania wykresów splajnów
34 Catmulla-Roma.
35
36 Splajn Catmulla-Roma można uznać za specjalny typ krzywej Beziera,
37 gwarantujący, że krzywa przetnie wszystkie punkty kontrolne poczynając
38 od drugiego a kończąc na przedostatnim. Dlatego minimalna liczba
39 punktów kontrolnych to 4.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README
64 %{perl_vendorlib}/Math/CatmullRom.pm
65 %{_mandir}/man3/*
This page took 0.124913 seconds and 3 git commands to generate.