]> git.pld-linux.org Git - packages/perl-Math-Brent.git/blob - perl-Math-Brent.spec
use generic url
[packages/perl-Math-Brent.git] / perl-Math-Brent.spec
1 %define         pdir    Math
2 %define         pnam    Brent
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        Math::Brent - single dimensional function minimisation
5 Summary(pl.UTF-8):      Math::Brent - jednowymiarowa minimalizacja funkcji
6 Name:           perl-Math-Brent
7 Version:        0.01
8 Release:        11
9 # same as perl
10 License:        GPL v1+ or Artistic
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
13 # Source0-md5:  c3cf5b1a0715846387f77f8e3983df5f
14 Patch0:         %{name}-man.patch
15 URL:            http://search.cpan.org/dist/Math-Brent/
16 BuildRequires:  perl-Math-Fortran
17 BuildRequires:  perl-Math-VecStat
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Math::Brent Perl module is an implementation of Brent's method for
25 One-Dimensional minimisation of a function without using derivatives.
26 This algorithm cleverly uses both the Golden Section Search and
27 parabolic interpolation.
28
29 %description -l pl.UTF-8
30 Moduł Perla Math::Brent stanowi implementację metody Brenta dla
31 jednowymiarowej minimalizacji funkcji bez korzystania z pochodnych.
32 Algorytm ten zręcznie korzysta zarówno ze znajdowania złotego
33 podziału, jak też z interpolacji kwadratowej.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37 %patch0 -p0
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README
56 %{perl_vendorlib}/Math/Brent.pm
57 %{_mandir}/man3/*
This page took 0.034608 seconds and 3 git commands to generate.