]> git.pld-linux.org Git - packages/perl-Math-Brent.git/blob - perl-Math-Brent.spec
27f7b779e35431769c3b683b608f0dcfd0ea1647
[packages/perl-Math-Brent.git] / perl-Math-Brent.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define         pdir    Math
3 %define         pnam    Brent
4 Summary:        Math::Brent - single dimensional function minimisation
5 Summary(pl.UTF-8):      Math::Brent - jednowymiarowa minimalizacja funkcji
6 Name:           perl-Math-Brent
7 Version:        0.01
8 Release:        11
9 # same as perl
10 License:        GPL v1+ or Artistic
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
13 # Source0-md5:  c3cf5b1a0715846387f77f8e3983df5f
14 Patch0:         %{name}-man.patch
15 BuildRequires:  rpm-perlprov >= 4.1-13
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  perl-Math-Fortran
18 BuildRequires:  perl-Math-VecStat
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Math::Brent Perl module is an implementation of Brent's method for
24 One-Dimensional minimisation of a function without using derivatives.
25 This algorithm cleverly uses both the Golden Section Search and
26 parabolic interpolation.
27
28 %description -l pl.UTF-8
29 Moduł Perla Math::Brent stanowi implementację metody Brenta dla
30 jednowymiarowej minimalizacji funkcji bez korzystania z pochodnych.
31 Algorytm ten zręcznie korzysta zarówno ze znajdowania złotego
32 podziału, jak też z interpolacji kwadratowej.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36 %patch0 -p0
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc README
55 %{perl_vendorlib}/Math/Brent.pm
56 %{_mandir}/man3/*
This page took 0.05351 seconds and 2 git commands to generate.