]> git.pld-linux.org Git - packages/perl-Math-BooleanEval.git/blob - perl-Math-BooleanEval.spec
use generic url
[packages/perl-Math-BooleanEval.git] / perl-Math-BooleanEval.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    BooleanEval
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Math::BooleanEval Perl module - Boolean expression parser
9 Summary(pl.UTF-8):      Moduł Perla Math::BooleanEval - analiza wyrażeń logicznych
10 Name:           perl-Math-BooleanEval
11 Version:        1.00
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  1400c67b1d3ab47a9c44d88b62c9aa3a
18 URL:            http://search.cpan.org/dist/Math-BooleanEval/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 BooleanEval parses a boolean expression and creates an array of
26 elements in the expression. By setting each element to 1 or 0 you can
27 evaluate the expression.
28
29 %description -l pl.UTF-8
30 BooleanEval analizuje wyrażenie logiczne i tworzy tablicę składników
31 wyrażenia. Poprzez ustawienie każdego elementu na 1 lub 0 można
32 obliczyć wyrażenie.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/Math/BooleanEval.pm
57 %{_mandir}/man3/*
This page took 0.079264 seconds and 3 git commands to generate.