]> git.pld-linux.org Git - packages/perl-Math-BigInt.git/blob - perl-Math-BigInt.spec
c1fc31f81052981209db4b37a8fc7ba80ed502b5
[packages/perl-Math-BigInt.git] / perl-Math-BigInt.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    BigInt
8 Summary:        New versions of Math::BigInt and Math::BigFloat Perl modules
9 Summary(pl.UTF-8):      Nowe wersje modułów Perla Math::BigInt i Math::BigFloat
10 Name:           perl-Math-BigInt
11 Version:        1.999726
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  3e45e459ece367a6b29a79b2f7363ba0
18 URL:            http://search.cpan.org/dist/Math-BigInt/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 # special case: if current perl-modules contain older releases, uncomment Requires and comment Conflicts below
22 #Requires:      perl-Math-BigInt-FastCalc >= 0.27
23 #Requires:      perl-Math-BigRat >= 0.2602
24 #Requires:      perl-bignum >= 0.22
25 Conflicts:      perl-Math-BigInt-FastCalc < 0.27
26 Conflicts:      perl-Math-BigInt-GMP < 1.37
27 Conflicts:      perl-Math-BigInt-Pari < 1.16
28 Conflicts:      perl-Math-BigRat < 0.2602
29 Conflicts:      perl-bignum < 0.22
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 New versions of Math::BigInt and Math::BigFloat.
35
36 %description -l pl.UTF-8
37 Nowe wersje modułów Math::BigInt i Math::BigFloat.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test INST_ARCHLIB=t}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc BENCHMARK BUGS CHANGES CREDITS GOALS HISTORY LICENSE NEW README TODO
64 %{perl_vendorlib}/Math/BigFloat.pm
65 %{perl_vendorlib}/Math/BigInt.pm
66 %{perl_vendorlib}/Math/BigInt/Calc.pm
67 %{perl_vendorlib}/Math/BigInt/CalcEmu.pm
68 %{_mandir}/man3/Math::BigFloat.3pm*
69 %{_mandir}/man3/Math::BigInt.3pm*
70 %{_mandir}/man3/Math::BigInt::Calc.3pm*
71 %{_mandir}/man3/Math::BigInt::CalcEmu.3pm*
72 %dir %{_examplesdir}/%{name}-%{version}
73 %{_examplesdir}/%{name}-%{version}/*.txt
74 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
This page took 0.058549 seconds and 2 git commands to generate.