]> git.pld-linux.org Git - packages/perl-Math-BigInt.git/blob - perl-Math-BigInt.spec
- updated to 1.999802
[packages/perl-Math-BigInt.git] / perl-Math-BigInt.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    BigInt
8 Summary:        New versions of Math::BigInt and Math::BigFloat Perl modules
9 Summary(pl.UTF-8):      Nowe wersje modułów Perla Math::BigInt i Math::BigFloat
10 Name:           perl-Math-BigInt
11 Version:        1.999802
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  07bfbbabe6eb1a161c0bbbbd73242b20
18 URL:            http://search.cpan.org/dist/Math-BigInt/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Math-Complex >= 1.39
23 BuildRequires:  perl-Test-Simple >= 0.94
24 %endif
25 # special case: if current perl-modules contain older releases, uncomment Requires and comment Conflicts below
26 #Requires:      perl-Math-BigInt-FastCalc >= 0.27
27 #Requires:      perl-Math-BigRat >= 0.2602
28 #Requires:      perl-bignum >= 0.22
29 Conflicts:      perl-Math-BigInt-FastCalc < 0.27
30 Conflicts:      perl-Math-BigInt-GMP < 1.37
31 Conflicts:      perl-Math-BigInt-Pari < 1.16
32 Conflicts:      perl-Math-BigRat < 0.2602
33 Conflicts:      perl-bignum < 0.22
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 New versions of Math::BigInt and Math::BigFloat.
39
40 %description -l pl.UTF-8
41 Nowe wersje modułów Math::BigInt i Math::BigFloat.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test INST_ARCHLIB=t}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc BENCHMARK BUGS CHANGES CREDITS GOALS HISTORY LICENSE NEW README TODO
68 %{perl_vendorlib}/Math/BigFloat.pm
69 %{perl_vendorlib}/Math/BigInt.pm
70 %{perl_vendorlib}/Math/BigInt/Calc.pm
71 %{perl_vendorlib}/Math/BigInt/CalcEmu.pm
72 %{perl_vendorlib}/Math/BigInt/Lib.pm
73 %{_mandir}/man3/Math::BigFloat.3pm*
74 %{_mandir}/man3/Math::BigInt.3pm*
75 %{_mandir}/man3/Math::BigInt::Calc.3pm*
76 %{_mandir}/man3/Math::BigInt::CalcEmu.3pm*
77 %{_mandir}/man3/Math::BigInt::Lib.3pm*
78 %dir %{_examplesdir}/%{name}-%{version}
79 %{_examplesdir}/%{name}-%{version}/*.txt
80 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
This page took 0.047613 seconds and 3 git commands to generate.