]> git.pld-linux.org Git - packages/perl-Math-BigInt-GMP.git/blob - perl-Math-BigInt-GMP.spec
- rel 2
[packages/perl-Math-BigInt-GMP.git] / perl-Math-BigInt-GMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    BigInt-GMP
8 Summary:        Math::BigInt::GMP - use the GMP library for Math::BigInt routines
9 Summary(pl.UTF-8):      Math::BigInt::GMP - wykorzystanie biblioteki GMP do funkcji Math::BigInt
10 Name:           perl-Math-BigInt-GMP
11 Version:        1.18
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  cd17afa7e9e7e9192457f6968d538f3f
18 BuildRequires:  gmp-devel
19 BuildRequires:  perl-Math-BigInt >= 1.76
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Requires:       perl-Math-BigInt >= 1.76
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Math::BigInt::GMP provides support for big integer calculations via
27 means of the GMP C-library. Math::BigInt::GMP now no longer uses
28 Math::GMP, but provides it's own XS layer to access the GMP C-library.
29 This cuts out another (perl sub routine) layer and also reduces the
30 memory footprint by not loading Math::GMP and Carp at all.
31
32 %description -l pl.UTF-8
33 Math::BigInt::GMP dostarcza obsługę obliczeń na wielkich liczbach
34 całkowitych z wykorzystaniem funkcjonalności biblioteki C GMP. Moduł
35 ten już nie używa Math::GMP, ale dostarcza własną warstwę XS do
36 odwoływania się do biblioteki GMP w C. Dzięki temu nie ma kolejnej
37 warstwy (podprocedury Perla), a wykorzystanie pamięci jest mniejsze
38 dzięki nie wczytywaniu modułów Math::GMP i Carp.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make} \
47         CC="%{__cc}" \
48         OPTIMIZE="%{rpmcflags}"
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc BUGS CHANGES CREDITS LICENSE README TODO
64 %{perl_vendorarch}/Math/BigInt/GMP.pm
65 %dir %{perl_vendorarch}/auto/Math/BigInt/GMP
66 %{perl_vendorarch}/auto/Math/BigInt/GMP/GMP.bs
67 %attr(755,root,root) %{perl_vendorarch}/auto/Math/BigInt/GMP/GMP.so
68 %{_mandir}/man3/*
This page took 0.0604 seconds and 4 git commands to generate.