]> git.pld-linux.org Git - packages/perl-Math-BigInt-GMP.git/blob - perl-Math-BigInt-GMP.spec
75cd7685c9d999beceed4961d0dc86f0de6d0a4d
[packages/perl-Math-BigInt-GMP.git] / perl-Math-BigInt-GMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    BigInt-GMP
8 Summary:        Math::BigInt::GMP - use the GMP library for Math::BigInt routines
9 Summary(pl.UTF-8):      Math::BigInt::GMP - wykorzystanie biblioteki GMP do funkcji Math::BigInt
10 Name:           perl-Math-BigInt-GMP
11 Version:        1.6001
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  c1697f2f2aaa640faf56fbd268cd54c1
18 URL:            http://search.cpan.org/dist/Math-BigInt-GMP/
19 BuildRequires:  gmp-devel
20 BuildRequires:  perl-Math-BigInt >= 1.999801
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-Test-Simple >= 0.94
25 %endif
26 Requires:       perl-Math-BigInt >= 1.999801
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Math::BigInt::GMP provides support for big integer calculations via
31 means of the GMP C-library. Math::BigInt::GMP now no longer uses
32 Math::GMP, but provides it's own XS layer to access the GMP C-library.
33 This cuts out another (perl sub routine) layer and also reduces the
34 memory footprint by not loading Math::GMP and Carp at all.
35
36 %description -l pl.UTF-8
37 Math::BigInt::GMP dostarcza obsługę obliczeń na wielkich liczbach
38 całkowitych z wykorzystaniem funkcjonalności biblioteki C GMP. Moduł
39 ten już nie używa Math::GMP, ale dostarcza własną warstwę XS do
40 odwoływania się do biblioteki GMP w C. Dzięki temu nie ma kolejnej
41 warstwy (podprocedury Perla), a wykorzystanie pamięci jest mniejsze
42 dzięki nie wczytywaniu modułów Math::GMP i Carp.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make} \
51         CC="%{__cc}" \
52         OPTIMIZE="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc BUGS CHANGES CREDITS LICENSE README TODO
68 %{perl_vendorarch}/Math/BigInt/GMP.pm
69 %dir %{perl_vendorarch}/auto/Math/BigInt/GMP
70 %attr(755,root,root) %{perl_vendorarch}/auto/Math/BigInt/GMP/GMP.so
71 %{_mandir}/man3/Math::BigInt::GMP.3pm*
This page took 0.05025 seconds and 2 git commands to generate.