]> git.pld-linux.org Git - packages/perl-Math-Base36.git/blob - perl-Math-Base36.spec
use generic url
[packages/perl-Math-Base36.git] / perl-Math-Base36.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    Base36
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Math::Base36 Perl module - encoding and decoding of base36 strings
9 Summary(pl.UTF-8):      Moduł Perla Math::Base36 - kodowanie i dekodowanie łańcuchów base36
10 Name:           perl-Math-Base36
11 Version:        0.09
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  3af1a961e45c0e367e78685a518f5dde
18 URL:            http://search.cpan.org/dist/Math-Base36/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module converts to and from Base36 numbers (0..9 - A..Z).
26
27 %description -l pl.UTF-8
28 Ten moduł konwertuje do i z liczb Base36 (w systemie o podstawie 36 -
29 z cyframi 0..9,A..Z).
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make}
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes
53 %{perl_vendorlib}/Math/Base36.pm
54 %{_mandir}/man3/*
This page took 0.095757 seconds and 3 git commands to generate.