]> git.pld-linux.org Git - packages/perl-Mail-Thread.git/blob - perl-Mail-Thread.spec
use generic url
[packages/perl-Mail-Thread.git] / perl-Mail-Thread.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Mail
6 %define         pnam    Thread
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Mail::Thread - Perl implementation of JWZ's mail threading algorithm
9 Summary(pl.UTF-8):      Mail::Thread - perlowa implementacja algorytmu wątkowania poczty JWZ
10 Name:           perl-Mail-Thread
11 Version:        2.55
12 Release:        1
13 Epoch:          1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  3b30d3087e30462cb6391797ee885f0e
19 URL:            http://search.cpan.org/dist/Mail-Thread/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl(Mail::Internet)
24 BuildRequires:  perl-Email-Abstract
25 BuildRequires:  perl-Test-Simple
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module implements something relatively close to Jamie Zawinski's
32 mail threading algorithm, as described by
33 http://www.jwz.org/doc/threading.html. Any deviations from the
34 algorithm are accidental.
35
36 %description -l pl.UTF-8
37 Ten moduł jest implementacją czegoś w miarę bliskiego do algorytmu
38 wątkowania poczty autorstwa Jamie Zawinskiego, opisanego w
39 http://www.jwz.org/doc/threading.html. Wszelkie odchylenia od
40 algorytmu są przypadkowe.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes
64 %{perl_vendorlib}/Mail/*.pm
65 %{_mandir}/man3/*
This page took 0.077968 seconds and 3 git commands to generate.