]> git.pld-linux.org Git - packages/perl-Mail-SpamTest-Bayesian.git/blob - perl-Mail-SpamTest-Bayesian.spec
use generic url
[packages/perl-Mail-SpamTest-Bayesian.git] / perl-Mail-SpamTest-Bayesian.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Mail
6 %define         pnam    SpamTest-Bayesian
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Mail::SpamTest::Bayesian - Perl extension for Bayesian spam-testing
9 Summary(pl.UTF-8):      Mail::SpamTest::Bayesian - rozszerzenie Perla do wykrywania spamu metodą bayesowską
10 Name:           perl-Mail-SpamTest-Bayesian
11 Version:        0.02
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b3656a57490c6ff342ba180da3ec9762
18 URL:            http://search.cpan.org/dist/Mail-SpamTest-Bayesian/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 %if %{with tests}
21 BuildRequires:  perl(MIME::Parser) >= 5.406
22 BuildRequires:  perl-BerkeleyDB >= 0.17
23 %endif
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module implements the Bayesian spam-testing algorithm described
30 by Paul Graham at <http://www.paulgraham.com/spam.html>.
31
32 In short: the system is trained by exposure to mailboxes of known spam
33 and non-spam messages. These are (1) MIME-decoded, and non-text parts
34 deleted; (2) tokenised. The database files spam.db and nonspam.db
35 contain lists of tokens and the number of messages in which they have
36 occurred; general.db holds a message count.
37
38 %description -l pl.UTF-8
39 Ten moduł jest implementacją bayesowskiego algorytmu wykrywania spamu
40 opisanego przez Paula Grahama w <http://www.paulgraham.com/spam.html>.
41
42 W skrócie: system jest uczony poprzez przedstawianie skrzynek z
43 wiadomościami, o których wiadomo, że zawierają spam lub go nie
44 zawierają. Są one (1) zakodowane MIME, z usuniętymi częściami
45 nietekstowymi; (2) ztokenizowane. Pliki baz danych spam.db i
46 nonspam.db zawierają listy tokenów i liczby wiadomości, w których
47 wystąpiły; general.db przechowuje liczbę wiadomości.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Change* README
71 %dir %{perl_vendorlib}/Mail/SpamTest
72 %{perl_vendorlib}/Mail/SpamTest/*.pm
73 %{_mandir}/man3/*
This page took 0.08927 seconds and 3 git commands to generate.