]> git.pld-linux.org Git - packages/perl-MIME-Fast.git/blob - perl-MIME-Fast.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-MIME-Fast.git] / perl-MIME-Fast.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    MIME
6 %define         pnam    Fast
7 Summary:        MIME::Fast - parsing MIME messages (wrapper for C gmime library)
8 Summary(pl.UTF-8):      MIME::Fast - przetwarzanie wiadomości MIME (interfejs do biblioteki gmime)
9 Name:           perl-MIME-Fast
10 Version:        1.6
11 Release:        5
12 # same as perl or GPL v2
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/MIME/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3c6466c7645bed52ae6bbce9705e3814
17 Patch0:         %{name}-gmime.patch
18 URL:            http://search.cpan.org/dist/MIME-Fast/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 # Can't test with earlier versions of gmime-2
22 BuildRequires:  gmime-devel >= 2.1.0
23 %if %{with tests}
24 BuildRequires:  perl(Test::More)
25 # We don't have this
26 #BuildRequires: perl-PerlIO-gzip
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 MIME::Fast is a perl module for creating, editing and parsing MIME
32 messages.  This module is based on the very good C library called
33 gmime (currently in development). MIME::Fast outght to be faster and
34 should use less memory and CPU resources than standard MIME (perl
35 module), because MIME::Fast is the wrapper for C functions (calling
36 C function is much, much less expensive than calling perl function).
37
38 %description -l pl.UTF-8
39 MIME::Fast to moduł Perla do tworzenia, edycji i analizy wiadomości
40 MIME. Ten moduł jest oparty na bardzo dobrej bibliotece C o nazwie
41 gmime (aktualnie rozwijanej). MIME::Fast powinien być szybszy i używać
42 mniej pamięci oraz zasobów procesora niż standardowy moduł Perla MIME,
43 ponieważ jest interfejsem do funkcji w C (wywołanie funkcji C jest
44 dużo, dużo mniej kosztowne niż wywołanie funkcji perlowej).
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48 %patch0 -p1
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make} \
54         CC="%{__cc}" \
55         OPTIMIZE="%{rpmcflags}"
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README TODO
71 %{perl_vendorarch}/MIME/Fast.pm
72 %dir %{perl_vendorarch}/auto/MIME/Fast
73 %attr(755,root,root) %{perl_vendorarch}/auto/MIME/Fast/*.so
74 %{_mandir}/man3/*
This page took 0.113059 seconds and 3 git commands to generate.