]> git.pld-linux.org Git - packages/perl-MIME-Base64.git/blob - perl-MIME-Base64.spec
- updated to 3.14
[packages/perl-MIME-Base64.git] / perl-MIME-Base64.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    MIME
7 %define         pnam    Base64
8 Summary:        Base64 and QuotedPrintable encoders/decoders for Perl
9 Summary(pl.UTF-8):      Funkcje dla Perla kodujące i dekodujące Base64 i QuotedPrintable
10 Name:           perl-MIME-Base64
11 Version:        3.14
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/MIME/GAAS/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  66185dd11586d724245ba957db561e75
18 URL:            http://search.cpan.org/dist/MIME-Base64/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _noautoreq      'perl(Encode)'
24
25 %description
26 This package contains a base64 encoder/decoder and a quoted-printable
27 encoder/decoder. These encoding methods are specified in RFC 2045 -
28 MIME (Multipurpose Internet Mail Extensions).
29
30 The Base64 encoding is designed to represent arbitrary sequences of
31 octets in a form that need not be humanly readable. A 65-character
32 subset ([A-Za-z0-9+/=]) of US-ASCII is used, enabling 6 bits to be
33 represented per printable character.
34
35 The quoted-printable encoding is intended to represent data that
36 largely consists of bytes that correspond to printable characters in
37 the ASCII character set. Non-printable characters are represented by a
38 triplet consisting of the character "=" followed by two hexadecimal
39 digits.
40
41 %description -l pl.UTF-8
42 Ten pakiet zawiera (de)kodery base64 i quoted-printable. Metody te
43 określone są w RFC 2045 - MIME (Multipurpose Internet Mail
44 Extensions).
45
46 Kod base64 zaprojektowano do reprezentowania określonej sekwencji
47 oktetów w formie, która nie musi być czytelna dla człowieka. Używany
48 jest 65-znakowy ([A-Za-z0-9+/=]) podzestaw z zestawu US-ASCII,
49 reprezentując każdy znak drukowalny sześcioma bitami.
50
51 Kod quoted-printable stosuje się do reprezentacji danych, które w
52 większości zawierają znaki drukowalne ASCII. Znaki niedrukowalne są
53 kodowane w triplety zawierające poprzedzone znakiem "=" dwie cyfry
54 szesnastkowe.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make} \
63         CC="%{__cc}" \
64         OPTIMIZE="%{rpmcflags}"
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc README Changes
80 %{perl_vendorarch}/MIME/Base64.pm
81 %{perl_vendorarch}/MIME/QuotedPrint.pm
82 %dir %{perl_vendorarch}/MIME
83 %dir %{perl_vendorarch}/auto/MIME
84 %dir %{perl_vendorarch}/auto/MIME/Base64
85 %attr(755,root,root) %{perl_vendorarch}/auto/MIME/Base64/Base64.so
86 %{_mandir}/man3/MIME::Base64.3pm*
87 %{_mandir}/man3/MIME::QuotedPrint.3pm*
This page took 0.102494 seconds and 3 git commands to generate.