]> git.pld-linux.org Git - packages/perl-MIDI-Perl.git/blob - perl-MIDI-Perl.spec
use generic url
[packages/perl-MIDI-Perl.git] / perl-MIDI-Perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    MIDI
6 %define         pnam    Perl
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        MIDI::Perl perl module
9 Summary(pl.UTF-8):      Moduł perla MIDI::Perl
10 Name:           perl-MIDI-Perl
11 Version:        0.82
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  a4f1c45483b460b4059664cde8636de1
18 URL:            http://search.cpan.org/dist/MIDI-Perl/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 MIDI::Perl is a suite of Perl modules that allows you to read,
26 compose, modify, and write MIDI files.
27
28 %description -l pl.UTF-8
29 MIDI::Perl jest zestawem modułów umożliwiających czytanie, tworzenie,
30 modyfikowanie i zapis plików MIDI.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 # get rid of pod documentation
49 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/MIDI/*.pod
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc ChangeLog README
57 %{perl_vendorlib}/MIDI.pm
58 %{perl_vendorlib}/MIDI
59 %{_mandir}/man3/*
This page took 0.066829 seconds and 3 git commands to generate.