]> git.pld-linux.org Git - packages/perl-Locale-Maketext.git/blob - perl-Locale-Maketext.spec
- updated URL and macros
[packages/perl-Locale-Maketext.git] / perl-Locale-Maketext.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         pdir    Locale
6 %define         pnam    Maketext
7 Summary:        Locale::Maketext - framework for localization
8 Summary(pl.UTF-8):      Locale::Maketext - szkielet do lokalizacji programów
9 Name:           perl-Locale-Maketext
10 Version:        1.32
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Locale/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  fd3428820f4155213a4de59e90564405
17 URL:            https://metacpan.org/dist/Locale-Maketext
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 Requires:       perl-dirs >= 2.1-15
22 %if %{with tests}
23 BuildRequires:  perl-I18N-LangTags >= 0.31
24 %endif
25 Requires:       perl-I18N-LangTags >= 0.31
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 It is a common feature of applications (whether run directly, or via
31 the Web) for them to be "localized" - i.e., for them to a present an
32 English interface to an English-speaker, a German interface to a
33 German-speaker, and so on for all languages it's programmed with.
34
35 Locale::Maketext is a framework for software localization; it provides
36 you with the tools for organizing and accessing the bits of text and
37 text-processing code that you need for producing localized
38 applications.
39
40 %description -l pl.UTF-8
41 Często spotykaną cechą programów (uruchamianych bezpośrednio lub przez
42 WWW) jest ich lokalizacja, czyli umiejętność prezentowania
43 angielskiego interfejsu użytkownikowi anglojęzycznemu, niemieckiego -
44 niemieckojęzycznemu i tak dalej dla wszystkich języków, dla których
45 istnieją tłumaczenia.
46
47 Locale::Maketext jest szkieletem do tworzenia zlokalizowanych
48 programów; udostępnia Ci narzędzia do organizowania i odwoływania się
49 do fragmentów tekstu, oraz potrzebnego Ci przy tworzeniu
50 zlokalizowanego oprogramowania kodu przetwarzającego tekst.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %{__make} pure_install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Locale/Maketext.pod
68 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Locale/Maketext/*.pod
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc ChangeLog README
76 %{perl_vendorlib}/Locale/Maketext.pm
77 %{perl_vendorlib}/Locale/Maketext
78 %{_mandir}/man3/Locale::Maketext*.3pm*
This page took 0.087765 seconds and 3 git commands to generate.