]> git.pld-linux.org Git - packages/perl-List-Combination.git/blob - perl-List-Combination.spec
use generic url
[packages/perl-List-Combination.git] / perl-List-Combination.spec
1 %define         pdir    List
2 %define         pnam    Combination
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        List::Combination - an iterator over the combinations of an array
5 Summary(pl.UTF-8):      List::Combination - iterator po kombinacjach tablicy
6 Name:           perl-List-Combination
7 Version:        1.00
8 Release:        4
9 License:        unknown
10 Group:          Development/Languages/Perl
11 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.pm.gz
12 # Source0-md5:  15f3e07012320c5a1c9d91f40ac03550
13 URL:            http://search.cpan.org/dist/List-Combination/
14 BuildRequires:  perl-devel >= 1:5.8.0
15 BuildRequires:  rpm-perlprov >= 4.1-13
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This class provides the ability to iterate over all the combinations,
21 of a given size, of the objects in an array.
22
23 %description -l pl.UTF-8
24 Ta klasa daje możliwość iterowania po wszystkich (danej długości)
25 kombinacjach obiektów tablicy.
26
27 %prep
28 %setup -q -c -T
29 %{__gzip} -dc %{_sourcedir}/List-Combination-%{version}.pm.gz > Combination.pm
30
31 %build
32 touch Makefile.PL
33 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"List::Combination");' \
34         INSTALLDIRS=vendor
35 %{__make}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 %{__make} install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %{perl_vendorlib}/%{pdir}/*.pm
49 %{_mandir}/man3/*
This page took 0.057744 seconds and 3 git commands to generate.