]> git.pld-linux.org Git - packages/perl-Lingua-Stem-Snowball-Da.git/blob - perl-Lingua-Stem-Snowball-Da.spec
use generic url
[packages/perl-Lingua-Stem-Snowball-Da.git] / perl-Lingua-Stem-Snowball-Da.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Lingua
6 %define         pnam    Stem-Snowball-Da
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Lingua::Stem::Snowball::Da - Porter's stemming algorithm for Danish
9 Summary(pl.UTF-8):      Lingua::Stem::Snowball::Da - algorytm Portera określający rdzenie słów dla języka duńskiego
10 Name:           perl-Lingua-Stem-Snowball-Da
11 Version:        1.01
12 Release:        4
13 License:        GPL v2
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e8d9a8285bce0c9e4bedc138cd6a1501
17 URL:            http://search.cpan.org/dist/Lingua-Stem-Snowball-Da/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The stem function takes a scalar as a parameter and stems the word
25 according to Martin Porter's Danish stemming algorithm, which can be
26 found at the Snowball website: http://snowball.tartarus.org/.
27
28 %description -l pl.UTF-8
29 Funkcja określająca rdzenie słów pobiera skalarny parametr i korzysta
30 z algorytmu dla języka duńskiego autorstwa Martina Portera. Algorytm
31 ten można znaleźć na stronie Snowballa: http://snowball.tartarus.org/.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49 cp -p stemmer.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/%{pdir}/Stem/Snowball/*.pm
58 %dir %{_examplesdir}/%{name}-%{version}
59 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
60 %{_mandir}/man3/*
This page took 0.08145 seconds and 3 git commands to generate.