]> git.pld-linux.org Git - packages/perl-Language-Functional.git/blob - perl-Language-Functional.spec
use generic url
[packages/perl-Language-Functional.git] / perl-Language-Functional.spec
1 %define         pdir    Language
2 %define         pnam    Functional
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        Language::Functional - makes Perl slightly more functional
5 Summary(pl.UTF-8):      Language::Functional - uczynienie Perla nieco bardziej funkcyjnym
6 Name:           perl-Language-Functional
7 Version:        0.05
8 Release:        1
9 # same as perl
10 License:        GPL v1+ or Artistic
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
13 # Source0-md5:  59c81abfd14c940f47115f19dc6288c2
14 URL:            http://search.cpan.org/dist/Language-Functional/
15 BuildRequires:  perl-devel >= 1:5.8.0
16 BuildRequires:  rpm-perlprov >= 4.1-13
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Perl already contains some functional-like functions, such as `map'
22 and `grep'. The purpose of this module is to add other functional-like
23 functions to Perl, such as foldl and foldr, as well as the use of
24 infinite lists.
25
26 %description -l pl.UTF-8
27 Perl ma zawiera trochę funkcji w stylu funkcyjnym, takich jak map czy
28 grep. Celem tego modułu jest dodanie większej liczby takich funkcji,
29 jak na przykład foldl i foldr, a także użycia nieskończonych list.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README
51 %{perl_vendorlib}/Language/Functional.pm
52 %{_mandir}/man3/*
This page took 0.072551 seconds and 3 git commands to generate.