]> git.pld-linux.org Git - packages/perl-LWP-Protocol-https.git/blob - perl-LWP-Protocol-https.spec
- tests BR: perl-Test-RequiresInternet
[packages/perl-LWP-Protocol-https.git] / perl-LWP-Protocol-https.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    LWP
6 %define         pnam    Protocol-https
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        LWP::Protocol::https - Provide https support for LWP::UserAgent
9 Summary(pl.UTF-8):      LWP::Protocol::https - obsługa https dla LWP::UserAgent
10 Name:           perl-LWP-Protocol-https
11 Version:        6.07
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/LWP/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b8943dfb7d187af63c36fc18ab15947d
18 URL:            http://search.cpan.org/dist/LWP-Protocol-https/
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-IO-Socket-SSL >= 1:1.54
23 BuildRequires:  perl-Mozilla-CA >= 20110101
24 BuildRequires:  perl-Net-HTTP >= 6
25 BuildRequires:  perl-Test-RequiresInternet
26 BuildRequires:  perl-Test-Simple
27 BuildRequires:  perl-libwww >= 6.06
28 %endif
29 Requires:       perl-Mozilla-CA
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 The LWP::Protocol::https module provide support for using https
35 schemed URLs with LWP. This module is a plug-in to the LWP protocol
36 handling, so you don't use it directly. Once the module is installed
37 LWP is able to access sites using HTTP over SSL/TLS.
38
39 %description -l pl.UTF-8
40 Moduł LWP::Protocol::https zapewnia obsługę URL-i ze schematu https w
41 LWP. Ten moduł jest wtyczką do obsługi protokołu w LWP, więc nie używa
42 się go bezpośrednio. Po zainstalowaniu modułu LWP potrafi łączyć się z
43 serwisami przy użyciu HTTP po SSL/TLS.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorlib}/LWP/Protocol/https.pm
68 %{_mandir}/man3/LWP::Protocol::https.3pm*
This page took 0.060146 seconds and 3 git commands to generate.