]> git.pld-linux.org Git - packages/perl-LWP-Online.git/blob - perl-LWP-Online.spec
new, version 1.08
[packages/perl-LWP-Online.git] / perl-LWP-Online.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    LWP
6 %define         pnam    Online
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        LWP::Online - Does your process have access to the web
9 Name:           perl-LWP-Online
10 Version:        1.08
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/LWP/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  20e25b3af8b84a493c730249c2a9c50d
17 URL:            http://search.cpan.org/dist/LWP-Online/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-URI >= 1.35
22 BuildRequires:  perl-libwww >= 5.805
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module attempts to answer, as accurately as it can, one of the
29 nastiest technical questions there is.
30
31 Am I on the internet?
32
33 The answer is useful in a wide range of decisions. For example...
34
35 Should my test scripts run the online portion of the tests or just
36 skip them?
37
38 Do I try to fetch fresh data from the server?
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/LWP/Online.pm
63 %{_mandir}/man3/LWP::Online.3pm*
This page took 0.088231 seconds and 3 git commands to generate.