]> git.pld-linux.org Git - packages/perl-Imager.git/blob - perl-Imager.spec
- updated to 0.43
[packages/perl-Imager.git] / perl-Imager.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Imager
7 %define pnam    Imager
8 Summary:        Imager - Perl extension for generating images
9 Summary(pl):    Imager - rozszerzenie Perla do generowania obrazków
10 Name:           perl-Imager
11 Version:        0.43
12 Release:        1
13 # same as perl
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  53b25b7de75625bfc9c9c3a44c8c2f76
18 Patch0:         %{name}-tiff.patch
19 URL:            http://www.develop-help.com/imager/
20 BuildRequires:  freetype-devel >= 2.0
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libpng-devel
23 BuildRequires:  libtiff-devel
24 # giflib >= 4.1.0-4 or libungif
25 BuildRequires:  libungif-devel >= 4.1.0
26 BuildRequires:  perl-devel >= 5.8.0
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Imager is a module for creating and altering images. It can read and
32 write various image formats, draw primitive shapes like lines, and
33 polygons, blend multiple images together in various ways, scale, crop,
34 render text and more.
35
36 %description -l pl
37 Imager to modu³ do tworzenia i modyfikowania obrazków. Potrafi czytaæ
38 i zapisywaæ ró¿ne formaty obrazków, rysowaæ proste kszta³ty takie jak
39 linie i wielok±ty, mieszaæ wiele obrazków razem na ró¿ne sposoby,
40 skalowaæ, obcinaæ, nanosiæ tekst itd.
41
42 %prep
43 %setup -q -n %{pnam}-%{version}
44 %patch -p1
45
46 %build
47 # manual configuration: we want freetype2 enabled and freetype1 disabled
48 # y/n for: win32, ft1, t1lib, ft2, tiff, png, ungif, jpeg, gif, nogif
49 IM_MANUAL=y \
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor <<EOF
52
53 n
54 n
55 n
56 y
57 y
58 y
59 y
60 y
61 n
62 n
63 EOF
64
65 %{__make} \
66         OPTIMIZE="%{rpmcflags}"
67
68 %{?with_tests:%{__make} test}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/Imager
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Imager/*.pod
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc Changes README
85 %{perl_vendorarch}/%{pdir}.pm
86 %{perl_vendorarch}/%{pdir}
87 %dir %{perl_vendorarch}/auto/%{pdir}
88 %{perl_vendorarch}/auto/%{pdir}/%{pdir}.bs
89 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/%{pdir}.so
90 %dir %{perl_vendorlib}/%{pdir}
91 %{_mandir}/man3/*
This page took 0.033259 seconds and 4 git commands to generate.