]> git.pld-linux.org Git - packages/perl-Image-Imlib2.git/blob - perl-Image-Imlib2.spec
- perl req/prov fix
[packages/perl-Image-Imlib2.git] / perl-Image-Imlib2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Image
7 %define         pnam    Imlib2
8 Summary:        Interface to the Imlib2 image library
9 Summary(pl.UTF-8):      Interfejs do biblioteki obrazów Imlib2
10 Name:           perl-Image-Imlib2
11 Version:        2.03
12 Release:        8
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Image/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  303b91fae2b863903e41a3cac34fa0d3
18 URL:            http://search.cpan.org/dist/Image-Imlib2/
19 BuildRequires:  imlib2-devel
20 BuildRequires:  perl-Module-Build >= 0.20
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Image::Imlib2 is a Perl port of Imlib2, a graphics library that does
27 image file loading and saving as well as manipulation, arbitrary
28 polygon support, etc. It does ALL of these operations FAST. It allows
29 you to create colour images using a large number of graphics
30 primitives, and output the images in a range of formats.
31
32 %description -l pl.UTF-8
33 Image::Imlib2 to perlowy port Imlib2 - biblioteki graficznej
34 wczytującej, zapisującej i przetwarzającej obrazy z obsługą dowolnych
35 wielokątów itp. Wykonuje WSZYSTKIE te operacje SZYBKO. Pozwala na
36 tworzenie kolorowych obrazów przy użyciu dużej liczby prymitywów
37 graficznych i zapis ich w wielu formatach.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor \
45         destdir=$RPM_BUILD_ROOT
46 %{__make} \
47         CC="%{__cc}" \
48         OPTIMIZE="%{rpmcflags}"
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 cd examples
60 for f in * ; do
61         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
62                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
63 done
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc CHANGES README
71 %{perl_vendorarch}/Image/Imlib2.pm
72 %dir %{perl_vendorarch}/auto/Image/Imlib2
73 %attr(755,root,root) %{perl_vendorarch}/auto/Image/Imlib2/*.so
74 %dir %{_examplesdir}/%{name}-%{version}
75 %{_examplesdir}/%{name}-%{version}/*.txt
76 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
77 %{_mandir}/man3/Image::Imlib2*.3pm*
This page took 0.076671 seconds and 3 git commands to generate.