]> git.pld-linux.org Git - packages/perl-IPC-Session.git/blob - perl-IPC-Session.spec
fd421a49bc6ac29aec3965c67c8eaba5f5d74e70
[packages/perl-IPC-Session.git] / perl-IPC-Session.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IPC
7 %define         pnam    Session
8 Summary:        Drive ssh or other interactive shell, local or remote (like 'expect')
9 Summary(pl.UTF-8):      Sterowanie ssh lub inną interaktywną powłoką lokalną lub zdalną (podobnie do expect)
10 Name:           perl-IPC-Session
11 Version:        0.05
12 Release:        4
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  aa56a95d08ebfc11edff3d9e9515d93c
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %{?with_tests:BuildRequires:    /bin/csh}
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 IPC::Session encapsulates the open3() function call (see the IPC::Open3
25 manpage) and its associated filehandles.  This makes it easy to maintain
26 multiple interactive command sessions, such as multiple persistent 'ssh'
27 and/or 'rsh' sessions, within the same perl script.
28
29 %description -l pl.UTF-8
30 IPC::Session obudowuje funkcję open3() (zobacz stronę podręcznika
31 systemowego dla IPC::Open3) i związane z nią uchwyty plików. Pozwala to
32 na łatwe zarządzanie wieloma interaktywnymi sesjami, np. w przypadku
33 wielu przezroczystych sesji 'ssh' i/lub 'rsh' w jednym skrypcie Perla.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc ChangeLog
57 %{perl_vendorlib}/IPC/Session.pm
58 %{_mandir}/man3/*.3pm*
This page took 0.060679 seconds and 2 git commands to generate.