]> git.pld-linux.org Git - packages/perl-IPC-Session.git/blob - perl-IPC-Session.spec
use generic url
[packages/perl-IPC-Session.git] / perl-IPC-Session.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    IPC
6 %define         pnam    Session
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Drive ssh or other interactive shell, local or remote (like 'expect')
9 Summary(pl.UTF-8):      Sterowanie ssh lub inną interaktywną powłoką lokalną lub zdalną (podobnie do expect)
10 Name:           perl-IPC-Session
11 Version:        0.05
12 Release:        4
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  aa56a95d08ebfc11edff3d9e9515d93c
17 URL:            http://search.cpan.org/dist/IPC-Session/
18 %{?with_tests:BuildRequires:    /bin/csh}
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 IPC::Session encapsulates the open3() function call (see the
26 IPC::Open3 manpage) and its associated filehandles. This makes it easy
27 to maintain multiple interactive command sessions, such as multiple
28 persistent 'ssh' and/or 'rsh' sessions, within the same perl script.
29
30 %description -l pl.UTF-8
31 IPC::Session obudowuje funkcję open3() (zobacz stronę podręcznika
32 systemowego dla IPC::Open3) i związane z nią uchwyty plików. Pozwala
33 to na łatwe zarządzanie wieloma interaktywnymi sesjami, np. w
34 przypadku wielu przezroczystych sesji 'ssh' i/lub 'rsh' w jednym
35 skrypcie Perla.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc ChangeLog
59 %{perl_vendorlib}/IPC/Session.pm
60 %{_mandir}/man3/*.3pm*
This page took 0.046647 seconds and 3 git commands to generate.