]> git.pld-linux.org Git - packages/perl-IO-Tty.git/blob - perl-IO-Tty.spec
rebuild with perl 5.32
[packages/perl-IO-Tty.git] / perl-IO-Tty.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %define         pdir    IO
6 %define         pnam    Tty
7 Summary:        IO::Tty and IO::Pty - interface to pseudo-ttys
8 Summary(pl.UTF-8):      IO::Tty i IO::Pty - interfejs do pseudo-tty
9 Name:           perl-IO-Tty
10 Version:        1.12
11 Release:        8
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/T/TO/TODDR/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  11695a1a516b3bd1b90ce75ff0ce3e6d
17 URL:            http://search.cpan.org/dist/IO-Tty/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 Requires:       perl-dirs >= 1.0-6
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 IO::Tty is used internally by IO::Pty to create a pseudo-tty.
25
26 IO::Pty provides an interface to allow the creation of a pseudo tty.
27
28 %description -l pl.UTF-8
29 Moduł IO::Tty jest używany wewnętrznie poprzez IO::Pty do tworzenia
30 pseudoterminali (pseudo-tty).
31
32 Moduł IO::Pty udostępnia interfejs pozwalający na utworzenie
33 pseudoterminala.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make} \
42         CC="%{__cc}" \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc ChangeLog README
59 %{perl_vendorarch}/IO/Pty.pm
60 %{perl_vendorarch}/IO/Tty.pm
61 %{perl_vendorarch}/IO/Tty
62 %dir %{perl_vendorarch}/auto/IO/Tty
63 %attr(755,root,root) %{perl_vendorarch}/auto/IO/Tty/Tty.so
64 %{_mandir}/man3/IO::Pty.3pm*
65 %{_mandir}/man3/IO::Tty*.3pm*
This page took 0.093384 seconds and 3 git commands to generate.