]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blob - perl-IO-Socket-SSL.spec
up to 2.067
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" - needs network connection
4 #
5 %define         pdir    IO
6 %define         pnam    Socket-SSL
7 Summary:        IO::Socket::SSL - nearly transparent SSL encapsulation for IO::Socket::INET
8 Summary(pl.UTF-8):      IO::Socket::SSL - prawie przezroczysta obudowa SSL dla IO::Socket::INET
9 Name:           perl-IO-Socket-SSL
10 Version:        2.067
11 Release:        1
12 Epoch:          1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  1d55e9f66ca442f4e0ae4d018e3067fc
18 URL:            http://search.cpan.org/dist/IO-Socket-SSL/
19 %if %{with tests}
20 BuildRequires:  perl-Net-SSLeay >= 1.46
21 BuildRequires:  perl-Scalar-List-Utils
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 # actually Net::SSLeay using openssl >= 0.9.8
26 Requires:       openssl >= 0.9.8
27 Suggests:       perl-Net-IDN-Encode
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This module is a true drop-in replacement for IO::Socket::INET that
33 uses SSL to encrypt data before it is transferred to a remote server
34 or client. IO::Socket::SSL supports all the extra features that one
35 needs to write a full-featured SSL client or server application:
36 multiple SSL contexts, cipher selection, certificate verification, and
37 SSL version selection. As an extra bonus, it works perfectly with
38 mod_perl.
39
40 %description -l pl.UTF-8
41 Ten moduł jest prawdziwym zamiennikiem dla IO::Socket::INET,
42 używającym SSL do kodowania danych przed przesyłaniem do zdalnego
43 serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
44 rzeczy potrzebne do napisania w pełni funkcjonalnego klienta lub
45 serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
46 certyfikatu, wybór wersji SSL. Ponadto wspaniale działa z mod_perlem.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 echo "n" | \
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/IO/Socket/SSL.pod
66
67 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68 install example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README docs/*
76 %{perl_vendorlib}/IO/Socket/SSL.pm
77 %{perl_vendorlib}/IO/Socket/SSL
78 %{_mandir}/man3/IO::Socket::SSL*.3pm*
79 %{_examplesdir}/%{name}-%{version}
This page took 0.079228 seconds and 3 git commands to generate.