]> git.pld-linux.org Git - packages/perl-IO-Interface.git/blob - perl-IO-Interface.spec
03afb643e7bafab65dff9d1e16329e16acc44796
[packages/perl-IO-Interface.git] / perl-IO-Interface.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 #
5 %define         pdir    IO
6 %define         pnam    Interface
7 Summary:        IO::Interface - Perl extension to access interface information
8 Summary(pl.UTF-8):      IO::Interface - rozszerzenie Perla do dostępu do informacji o interfejsach
9 Name:           perl-IO-Interface
10 Version:        1.08
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  38c292a4d0976dd38179cfbfdca5e777
17 URL:            http://search.cpan.org/dist/IO-Interface/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 IO::Interface adds methods to IO::Socket objects that allows them to
24 be used to retrieve and change information about the network
25 interfaces on your system.  In addition to the object-oriented access
26 methods, you can use a function-oriented style.
27
28 %description -l pl.UTF-8
29 IO::Interface dodaje do obiektów IO::Socket metody pozwalające na
30 używanie ich do pobierania i zmiany informacji o interfejsach
31 sieciowych w systemie. Oprócz metod zorientowanych obiektowo można
32 używać także wywołań zorientowanych na funkce.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40
41 %{__make} \
42         CC="%{__cc}" \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} pure_install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorarch}/IO/Interface.pm
60 %dir %{perl_vendorarch}/IO/Interface
61 %{perl_vendorarch}/IO/Interface/Simple.pm
62 %dir %{perl_vendorarch}/auto/IO/Interface
63 %attr(755,root,root) %{perl_vendorarch}/auto/IO/Interface/*.so
64 %{perl_vendorarch}/auto/IO/Interface/autosplit.ix
65 %{_mandir}/man3/*
This page took 0.052149 seconds and 2 git commands to generate.