]> git.pld-linux.org Git - packages/perl-IO-HTML.git/blob - perl-IO-HTML.spec
c9116a179711a0e277a867de004fe234a120dbd4
[packages/perl-IO-HTML.git] / perl-IO-HTML.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    IO
6 %define         pnam    HTML
7 Summary:        IO::HTML - Open an HTML file with automatic charset detection
8 Summary(pl.UTF-8):      IO::HTML - otwieranie pliku HTML z automatycznym wykrywaniem zestawu znaków
9 Name:           perl-IO-HTML
10 Version:        1.001
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3f8958718844dc96b9f6946f21d70d22
17 URL:            http://search.cpan.org/dist/IO-HTML/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Exporter) >= 5.57
23 BuildRequires:  perl-Encode >= 2.10
24 BuildRequires:  perl-Test-Simple >= 0.88
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 IO::HTML provides an easy way to open a file containing HTML while
31 automatically determining its encoding. It uses the HTML5 encoding
32 sniffing algorithm specified in section 8.2.2.1 of the draft standard.
33
34 %description -l pl.UTF-8
35 Moduł IO::HTML udostępnia łatwy sposób otwierania pliku zawierającego
36 HTML z automatycznym określaniem jego kodowania. Wykorzystuje algorytm
37 dopasowywania kodowania HTML5, opisany w sekcji 8.2.2.1 szkicu
38 standardu.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/IO/HTML.pm
63 %{_mandir}/man3/IO::HTML.3pm*
This page took 0.133967 seconds and 2 git commands to generate.