]> git.pld-linux.org Git - packages/perl-IO-File-Multi.git/blob - perl-IO-File-Multi.spec
use generic url
[packages/perl-IO-File-Multi.git] / perl-IO-File-Multi.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    IO
6 %define         pnam    File-Multi
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        IO::File::Multi perl module
9 Summary(pl.UTF-8):      Moduł perla IO::File::Multi
10 Name:           perl-IO-File-Multi
11 Version:        1.02
12 Release:        12
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  7ad39ab26c2b3554d883b896ab7e18cc
18 URL:            http://search.cpan.org/dist/IO-File-Multi/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Obsoletes:      perl-FileHandle-Multi
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 IO::File::Multi - Print to multiple filehandles with one output call.
27
28 %description -l pl.UTF-8
29 IO::File::Multi umożliwia pisanie do wielu uchwytów pliku jednocześnie
30 przy jednorazowym wywołaniu funkcji print() lub printf().
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes README
54 %dir %{perl_vendorlib}/IO/File
55 %{perl_vendorlib}/IO/File/Multi.pm
56 %{_mandir}/man3/*
This page took 0.047621 seconds and 3 git commands to generate.