]> git.pld-linux.org Git - packages/perl-IO-Digest.git/blob - perl-IO-Digest.spec
use generic url
[packages/perl-IO-Digest.git] / perl-IO-Digest.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    IO
6 %define         pnam    Digest
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        IO::Digest - calculate digests while reading or writing
9 Summary(pl.UTF-8):      IO::Digest - wyliczanie sum kontrolnych podczas odczytu lub zapisu
10 Name:           perl-IO-Digest
11 Version:        0.10
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  0448841e0559c2c19c7e8001ef087e26
18 Patch0:         %{name}-noninteractive.patch
19 URL:            http://search.cpan.org/dist/IO-Digest/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-PerlIO-via-dynamic
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The IO::Digest Perl module allows you to calculate digests while
30 reading or writing file handles. This avoids the case you need to
31 reread the same content to compute the digests after written a file.
32
33 %description -l pl.UTF-8
34 Moduł Perla IO::Digest umożliwia wyliczanie sum kontrolnych podczas
35 odczytu z lub zapisu do pliku. Pozwala to uniknąć ponownego odczytu
36 tej samej zawartości przy obliczaniu sum kontrolnych po zapisie do
37 pliku.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41 %patch0 -p1
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGES README
62 %{perl_vendorlib}/IO/Digest.pm
63 %{_mandir}/man3/*
This page took 0.042968 seconds and 3 git commands to generate.