]> git.pld-linux.org Git - packages/perl-IO-Capture.git/blob - perl-IO-Capture.spec
c913c9eb08354d531fd80640310dbf8da173b401
[packages/perl-IO-Capture.git] / perl-IO-Capture.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    IO
7 %define pnam    Capture
8 Summary:        IO::Capture - Abstract Base Class to build modules to capture output
9 Summary(pl.UTF-8):      IO::Capture - abstrakcyjna klasa bazowa dla modułów przechwytujących wyjście
10 Name:           perl-IO-Capture
11 Version:        0.05
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4760036d7fcf9f2cc34f2b2eefd511a4
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Simple
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The IO::Capture module defines an abstract base class that can be used
28 to build modules that capture output being sent on a filehandle such as
29 STDOUT or STDERR.
30
31 %description -l pl.UTF-8
32 Moduł IO::Capture definiuje abstrakcyjną klasę bazową, która może być
33 używana do tworzenia modułów przechwytujących wyjście wysyłane przez
34 uchwyt pliku, taki jak STDOUT czy STDERR.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc BUGS Changes README
58 %{perl_vendorlib}/IO/*.pm
59 %{perl_vendorlib}/IO/Capture
60 %{_mandir}/man3/*
This page took 0.053984 seconds and 2 git commands to generate.