]> git.pld-linux.org Git - packages/perl-IO-AIO.git/blob - perl-IO-AIO.spec
- release 2
[packages/perl-IO-AIO.git] / perl-IO-AIO.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IO
7 %define         pnam    AIO
8 Summary:        IO::AIO - Perl Asynchronous Input/Output
9 Summary(pl.UTF-8):      IO::AIO - asynchroniczne wejście/wyjście w Perlu
10 Name:           perl-IO-AIO
11 Version:        3.31
12 Release:        2
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  44d3ebf9e4b912b589264db2cf46b670
17 URL:            http://search.cpan.org/dist/IO-AIO/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module implements asynchronous I/O using whatever means your
24 operating system supports.
25
26 %description -l pl.UTF-8
27 Ten moduł implementuje asynchroniczne we/wy przy użyciu dowolnych
28 metod obsługiwanych przez system operacyjny.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36
37 %{__make} \
38         CC="%{__cc}" \
39         OPTIMIZE="%{rpmcflags}"
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %attr(755,root,root) %{_bindir}/treescan
56 %{perl_vendorarch}/IO/AIO.pm
57 %dir %{perl_vendorarch}/auto/IO/AIO
58 %{perl_vendorarch}/auto/IO/AIO/AIO.bs
59 %attr(755,root,root) %{perl_vendorarch}/auto/IO/AIO/AIO.so
60 %{_mandir}/man3/*
This page took 0.084866 seconds and 4 git commands to generate.