]> git.pld-linux.org Git - packages/perl-IO-AIO.git/blob - perl-IO-AIO.spec
- updated to 4.75
[packages/perl-IO-AIO.git] / perl-IO-AIO.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    IO
6 %define         pnam    AIO
7 Summary:        IO::AIO - Perl Asynchronous Input/Output
8 Summary(pl.UTF-8):      IO::AIO - asynchroniczne wejście/wyjście w Perlu
9 Name:           perl-IO-AIO
10 Version:        4.75
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  04edb0cb77d9ec19f73b8aa46d5b3d05
16 Patch0:         %{pdir}-%{pnam}-path.patch
17 URL:            https://metacpan.org/dist/IO-AIO
18 BuildRequires:  perl-Canary-Stability >= 2001
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.52
20 BuildRequires:  perl-devel >= 1:5.8.2
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 %if %{with tests}
24 BuildRequires:  perl-common-sense
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module implements asynchronous I/O using whatever means your
30 operating system supports.
31
32 %description -l pl.UTF-8
33 Ten moduł implementuje asynchroniczne we/wy przy użyciu dowolnych
34 metod obsługiwanych przez system operacyjny.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38 %patch0 -p1
39
40 %build
41 PERL_CANARY_STABILITY_NOPROMPT=1 \
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %attr(755,root,root) %{_bindir}/treescan
64 %{perl_vendorarch}/IO/AIO.pm
65 %dir %{perl_vendorarch}/auto/IO/AIO
66 %attr(755,root,root) %{perl_vendorarch}/auto/IO/AIO/AIO.so
67 %{_mandir}/man3/IO::AIO.3pm*
68 %{_mandir}/man1/treescan.1p*
This page took 0.070515 seconds and 3 git commands to generate.