]> git.pld-linux.org Git - packages/perl-HTTP-Cookies.git/blob - perl-HTTP-Cookies.spec
ddf65a3fc2c8e7ef79c9413c679de3c815d60b93
[packages/perl-HTTP-Cookies.git] / perl-HTTP-Cookies.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    HTTP
6 %define         pnam    Cookies
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        HTTP::Cookies - HTTP cookie jars
9 Summary(pl.UTF-8):      HTTP::Cookies - pojemnik na ciasteczka HTTP
10 Name:           perl-HTTP-Cookies
11 Version:        6.04
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/HTTP/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  7bf1e277bd5c886bc18d21eb8423b65f
18 URL:            http://search.cpan.org/dist/HTTP-Cookies/
19 BuildRequires:  perl-devel >= 1:5.8.8
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-HTTP-Date >= 6
23 BuildRequires:  perl-HTTP-Message >= 6
24 %endif
25 Requires:       perl-HTTP-Date >= 6
26 Requires:       perl-HTTP-Message >= 6
27 Conflicts:      perl-libwww < 6
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This class is for objects that represent a "cookie jar" -- that is, a
33 database of all the HTTP cookies that a given LWP::UserAgent object
34 knows about.
35
36 This module implements the old style cookies as well as the new style
37 cookies described in RFC 2965.
38
39 Instances of the class HTTP::Cookies are able to store a collection
40 of Set-Cookie2: and Set-Cookie: headers and are able to use this
41 information to initialize Cookie-headers in HTTP::Request objects.
42 The state of a HTTP::Cookies object can be saved in and restored from
43 files.
44
45 %description -l pl.UTF-8
46 Klasa HTTP::Cookies jest przeznaczona dla obiektów reprezentujących
47 "pojemniki na ciasteczka" - tzn. bazę danych wszystkich ciasteczek
48 HTTP, jakie zna dany obiekt LWP::UserAgent.
49
50 Ten moduł implementuje ciasteczka starego typu, jak i nowego,
51 opisanego w RFC 2965.
52
53 Instancje klasy HTTP::Cookies mogą przechowywać zbiór nagłówków
54 Set-Cookie2: oraz Set-Cookie: i wykorzystywać te informacje do
55 zainicjowania nagłówków Cookie w obiektach HTTP::Request. Stan
56 obiektu HTTP::Cookies można zapisać w pliku, a później z niego
57 odtworzyć.
58
59 %prep
60 %setup -q -n %{pdir}-%{pnam}-%{version}
61
62 %build
63 %{__perl} Makefile.PL \
64         INSTALLDIRS=vendor
65 %{__make}
66
67 %{?with_tests:%{__make} test}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} pure_install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc Changes
81 %{perl_vendorlib}/HTTP/Cookies.pm
82 %{perl_vendorlib}/HTTP/Cookies
83 %{_mandir}/man3/HTTP::Cookies*.3pm*
This page took 0.058711 seconds and 2 git commands to generate.