]> git.pld-linux.org Git - packages/perl-HTTP-Cookies.git/blob - perl-HTTP-Cookies.spec
94e8d76c1c2e26765b037f2d9c13b83d4e3962a4
[packages/perl-HTTP-Cookies.git] / perl-HTTP-Cookies.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    HTTP
6 %define         pnam    Cookies
7 Summary:        HTTP::Cookies - HTTP cookie jars
8 Summary(pl.UTF-8):      HTTP::Cookies - pojemnik na ciasteczka HTTP
9 Name:           perl-HTTP-Cookies
10 Version:        6.08
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/HTTP/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8c663710244e70c85775393a8f5be443
17 URL:            http://search.cpan.org/dist/HTTP-Cookies/
18 BuildRequires:  perl-devel >= 1:5.8.8
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-HTTP-Date >= 6
22 BuildRequires:  perl-HTTP-Message >= 6
23 %endif
24 Requires:       perl-HTTP-Date >= 6
25 Requires:       perl-HTTP-Message >= 6
26 Conflicts:      perl-libwww < 6
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This class is for objects that represent a "cookie jar" -- that is, a
32 database of all the HTTP cookies that a given LWP::UserAgent object
33 knows about.
34
35 This module implements the old style cookies as well as the new style
36 cookies described in RFC 2965.
37
38 Instances of the class HTTP::Cookies are able to store a collection
39 of Set-Cookie2: and Set-Cookie: headers and are able to use this
40 information to initialize Cookie-headers in HTTP::Request objects.
41 The state of a HTTP::Cookies object can be saved in and restored from
42 files.
43
44 %description -l pl.UTF-8
45 Klasa HTTP::Cookies jest przeznaczona dla obiektów reprezentujących
46 "pojemniki na ciasteczka" - tzn. bazę danych wszystkich ciasteczek
47 HTTP, jakie zna dany obiekt LWP::UserAgent.
48
49 Ten moduł implementuje ciasteczka starego typu, jak i nowego,
50 opisanego w RFC 2965.
51
52 Instancje klasy HTTP::Cookies mogą przechowywać zbiór nagłówków
53 Set-Cookie2: oraz Set-Cookie: i wykorzystywać te informacje do
54 zainicjowania nagłówków Cookie w obiektach HTTP::Request. Stan
55 obiektu HTTP::Cookies można zapisać w pliku, a później z niego
56 odtworzyć.
57
58 %prep
59 %setup -q -n %{pdir}-%{pnam}-%{version}
60
61 %build
62 %{__perl} Makefile.PL \
63         INSTALLDIRS=vendor
64 %{__make}
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} pure_install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes
80 %{perl_vendorlib}/HTTP/Cookies.pm
81 %{perl_vendorlib}/HTTP/Cookies
82 %{_mandir}/man3/HTTP::Cookies*.3pm*
This page took 0.040982 seconds and 2 git commands to generate.