]> git.pld-linux.org Git - packages/perl-HTML-Template.git/blob - perl-HTML-Template.spec
47c952f22cdb98a2b24a658eae39e4a0a6f1c266
[packages/perl-HTML-Template.git] / perl-HTML-Template.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    HTML
7 %define         pnam    Template
8 Summary:        HTML::Template - Perl module to use HTML templates from CGI scripts
9 Summary(pl.UTF-8):      HTML::Template - moduł Perla do obsługi szablonów HTML w skryptach CGI
10 Name:           perl-HTML-Template
11 Version:        2.94
12 Release:        1
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7b7683c3672d55fb922734ea1e9ba7e8
17 URL:            https://github.com/mpeters/html-template/
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-devel >= 1:5.8.0
20 %if %{with tests}
21 BuildRequires:  perl-Digest-MD5
22 BuildRequires:  perl-IPC-SharedCache
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module attempts make using HTML templates simple and natural.
29
30 It extends standard HTML with a few new HTML-esque tags - <TMPL_VAR>,
31 <TMPL_LOOP>, <TMPL_INCLUDE>, <TMPL_IF> and <TMPL_ELSE>.  The file written
32 with HTML and these new tags is called a template.  It is usually saved
33 separate from your script - possibly even created by someone else!
34
35 Using this module you fill in the values for the variables, loops and
36 branches declared in the template.  This allows you to seperate design -
37 the HTML - from the data, which you generate in the Perl script.
38
39 %description -l pl.UTF-8
40 HTML::Template jest modułem pozwalającym na wykorzystywanie szablonów
41 HTML (i nie tylko) w skryptach CGI (a także w dowolnym innym
42 oprogramowaniu przy tworzeniu którego zachodzi potrzeba rozdzielenia
43 programu od wyglądu danych.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:TEST_SHARED_MEMORY=1 TEST_FILE_CACHE=1 %{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/%{pdir}/%{pnam}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README ANNOUNCE FAQ templates scripts
69 %{perl_vendorlib}/%{pdir}/*.pm
70 %dir %{perl_vendorlib}/%{pdir}/%{pnam}
71 %{_mandir}/man3/*
This page took 0.023471 seconds and 2 git commands to generate.