]> git.pld-linux.org Git - packages/perl-HTML-Parser.git/blob - perl-HTML-Parser.spec
8918575bfb662593f8deabdbba4501565c7bfa11
[packages/perl-HTML-Parser.git] / perl-HTML-Parser.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4
5 %define         pdir    HTML
6 %define         pnam    Parser
7 Summary:        HTML::Parser - parsing and extracting information from HTML documents
8 Summary(cs.UTF-8):      HTML::Parser - modul pro parsování HTML v Perlu
9 Summary(pl.UTF-8):      HTML::Parser - analiza i wyciąganie informacji z dokumentów HTML
10 Summary(ru.UTF-8):      HTML::Parser - набор модулей для "разбора" HTML-документов
11 Summary(uk.UTF-8):      HTML::Parser - набір модулів для розбору HTML-документів
12 Summary(zh_CN.UTF-8):   Perl 的 HTML 解析器模块。
13 Name:           perl-HTML-Parser
14 Version:        3.75
15 Release:        1
16 # same as perl
17 License:        GPL v1+ or Artistic
18 Group:          Development/Languages/Perl
19 Source0:        https://www.cpan.org/modules/by-module/HTML/%{pdir}-%{pnam}-%{version}.tar.gz
20 # Source0-md5:  65bf65aa8b34b35443e094010f991406
21 URL:            https://search.cpan.org/dist/HTML-Parser/
22 BuildRequires:  perl-HTML-Tagset >= 3
23 BuildRequires:  perl-devel >= 1:5.8.0
24 %{?with_tests:BuildRequires:    perl-libwww}
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildConflicts: perl-HTML-Stream = 1.45-3
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # HTTP::Headers (perl-libwww) is not always required
30 %define         _noautoreq      perl(HTTP::Headers)
31
32 %description
33 Perl module HTML::Parser that allows to parse and extract information
34 from HTML documents.
35
36 %description -l cs.UTF-8
37 Balíček perl-HTML-Parser obsahuje modul pro Perl, který slouží k
38 parsování a extrahování informací z HTML dokumentu.
39
40 %description -l da.UTF-8
41 HTML::Parser modul til Perl for at tolka og extrahere information fra
42 HTML-dokument.
43
44 %description -l de.UTF-8
45 HTML::Parser modul für Perl zum Parsen und Extrahieren von
46 Informationen aus HTML-Dokumenten.
47
48 %description -l es.UTF-8
49 Módulo HTML::Parser para perl para analizar y extraer información a
50 partir de documentos HTML.
51
52 %description -l fr.UTF-8
53 Module HTML::Parser pour perl permettant d'analyser et d'extraire des
54 informations de documents HTML.
55
56 %description -l it.UTF-8
57 Il modulo HTML::Parser per perl, che consente di analizzare documenti
58 HTML e di estrarne informazioni.
59
60 %description -l ja.UTF-8
61 HTML ドキュメントから情報を解析、抽出するための Perl 用の HTML::Parser 。
62
63 %description -l ko.UTF-8
64 HTML::Parser 모줄은 펄이 HTML 문서들로 부터 정보를 파싱하고 가져오게끔 합니다.
65
66 %description -l pl.UTF-8
67 Moduł Perla HTML::Parser pozwalający na parsowanie i wyciąganie
68 informacji z dokumentu HTML.
69
70 %description -l pt_BR.UTF-8
71 Módulo Perl HTML::Parser - Uma coleção de módulos para examinar e
72 extrair informações de documentos HTML.
73
74 %description -l ru.UTF-8
75 HTML::Parser - набор модулей для "разбора" HTML-документов.
76
77 %description -l uk.UTF-8
78 HTML::Parser - набір модулів для розбору HTML-документів.
79
80 %description -l pt.UTF-8
81 O módulo HTML::Parser para o Perl analisar e extrair informações de
82 documentos HTML.
83
84 %description -l sv.UTF-8
85 HTML::Parser modul till perl för att tolka och extrahera information
86 från HTML-dokument.
87
88 %prep
89 %setup -q -n %{pdir}-%{pnam}-%{version}
90
91 %build
92 %{__perl} Makefile.PL \
93         INSTALLDIRS=vendor \
94         DEFINE="-DMARKED_SECTION -DUNICODE_ENTITIES" \
95         < /dev/null
96 %{__make} \
97         CC="%{__cc}" \
98         OPTIMIZE="%{rpmcflags}"
99
100 %{?with_tests:%{__make} test}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc Changes README TODO
114 %{perl_vendorarch}/HTML/Entities.pm
115 %{perl_vendorarch}/HTML/Filter.pm
116 %{perl_vendorarch}/HTML/HeadParser.pm
117 %{perl_vendorarch}/HTML/LinkExtor.pm
118 %{perl_vendorarch}/HTML/Parser.pm
119 %{perl_vendorarch}/HTML/PullParser.pm
120 %{perl_vendorarch}/HTML/TokeParser.pm
121 %dir %{perl_vendorarch}/auto/HTML/Parser
122 %attr(755,root,root) %{perl_vendorarch}/auto/HTML/Parser/Parser.so
123 %{_mandir}/man3/HTML::Entities.3pm*
124 %{_mandir}/man3/HTML::Filter.3pm*
125 %{_mandir}/man3/HTML::HeadParser.3pm*
126 %{_mandir}/man3/HTML::LinkExtor.3pm*
127 %{_mandir}/man3/HTML::Parser.3pm*
128 %{_mandir}/man3/HTML::PullParser.3pm*
129 %{_mandir}/man3/HTML::TokeParser.3pm*
This page took 0.0858100000000001 seconds and 2 git commands to generate.