]> git.pld-linux.org Git - packages/perl-HTML-Mason.git/blob - perl-HTML-Mason.spec
ae9a1bfa9ff6c5b910d1bfd17833fbfa4f8f45b6
[packages/perl-HTML-Mason.git] / perl-HTML-Mason.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    HTML
7 %define         pnam    Mason
8 Summary:        Mason Perl module - high-performance, dynamic web site authoring system
9 Summary(pl.UTF-8):      Moduł Perla Mason - wysokowydajny system do tworzenia dynamicznych stron WWW
10 Name:           perl-HTML-Mason
11 Version:        1.58
12 Release:        1
13 Epoch:          3
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  c48298e79b7ecb98eb2ad24f4c27f403
19 URL:            http://www.masonhq.com/
20 BuildRequires:  perl-Module-Build
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl(File::Spec) >= 0.8
25 BuildRequires:  perl(Scalar::Util) >= 1.01
26 BuildRequires:  perl-CGI >= 2.46
27 BuildRequires:  perl-Cache-Cache >= 1.0
28 BuildRequires:  perl-Class-Container >= 0.07
29 BuildRequires:  perl-Exception-Class >= 1.14
30 BuildRequires:  perl-HTML-Parser
31 BuildRequires:  perl-Log-Any
32 BuildRequires:  perl-Params-Validate >= 0.70
33 BuildRequires:  perl-Test-Deep
34 %endif
35 Requires:       perl(File::Spec) >= 0.8
36 Requires:       perl-Class-Container >= 0.07
37 Requires:       perl-Exception-Class >= 1.14
38 Requires:       perl-Params-Validate >= 0.70
39 Conflicts:      perl-Apache-Filter < 1.021
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _noautoreq_perl Cache::Cache HTML::Mason::Exceptions HTML::Mason::MethodMaker(read_write) Apache Apache::Constants Apache::Request
44
45 %description
46 Mason is a tool for building, serving and managing large web sites.
47 Its features make it an ideal backend for high load sites serving
48 dynamic content, such as online newspapers or database driven
49 e-commerce sites.
50
51 %description -l pl.UTF-8
52 Mason jest narzędziem służącym do budowania i udostępniania dużych
53 serwisów WWW oraz do zarządzania nimi. Ze względu na swe możliwości,
54 jest idealną bazą dla dużych serwisów o dynamicznie generowanej
55 zawartości, np. gazet internetowych czy sklepów internetowych opartych
56 na bazach danych.
57
58 %prep
59 %setup -q -n %{pdir}-%{pnam}-%{version}
60
61 %build
62 %{__perl} Makefile.PL \
63         INSTALLDIRS=vendor
64 %{__make}
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/MasonX
75
76 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/HTML/Mason/*.pod
77
78 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79 gzip -9nf samples/README
80 cp -a {samples,eg} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81 mv bin contrib
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc Changes README.md UPGRADE CREDITS contrib
89 %attr(755,root,root) %{_bindir}/*.pl
90 %{perl_vendorlib}/HTML/Mason.pm
91 %{perl_vendorlib}/HTML/Mason
92 %{_examplesdir}/%{name}-%{version}
93 # don't package bundle man page
94 %{_mandir}/man3/HTML*
95 %{perl_vendorlib}/MasonX
This page took 0.051558 seconds and 2 git commands to generate.