]> git.pld-linux.org Git - packages/perl-HTML-Latex.git/blob - perl-HTML-Latex.spec
use generic url
[packages/perl-HTML-Latex.git] / perl-HTML-Latex.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (failed on my machine)
4
5 %define         pdir    HTML
6 %define         pnam    Latex
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        HTML::Latex Perl module - creates a LaTeX file from an HTML file
9 Summary(pl.UTF-8):      Moduł Perla HTML::Latex - tworzenie pliku w LaTeXu z pliku HTML
10 Name:           perl-HTML-Latex
11 Version:        1.0
12 Release:        6
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b15c98fe9105340060e55e11c17747cb
17 URL:            http://search.cpan.org/dist/HTML-Latex/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-HTML-Tree
22 BuildRequires:  perl-XML-Simple >= 1.04
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Converts properly formatted HTML files, filehandles, or strings to
29 LaTeX. It offers several options in processing, such a the ignoring of
30 tags, the configuration of the TeX, and downloading of URLs. It is
31 also much easier to extend than any other html2latex converter.
32
33 %description -l pl.UTF-8
34 Moduł ten konwertuje odpowiednio sformatowane pliki HTML, uchwyty
35 plików lub łańcuchy znaków do LaTeXa. Oferuje przy przetwarzaniu kilka
36 opcji, takich jak ignorowanie znaczników, konfiguracja TeXa oraz
37 ściąganie odnośników. Jest dużo prostszy do rozbudowywania niż
38 jakikolwiek inny konwerter html2latex.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Change* README TODO
62 %{perl_vendorlib}/%{pdir}/*.pm
63 %{_mandir}/man3/*
This page took 0.044703 seconds and 3 git commands to generate.